Come confrontare 2 colonne in Excel e ricavarne le differenze

In Guide by Roberto0 Comments

Like
Like Love Haha Wow Sad Angry

Ieri un collega mi ha chiesto aiuto per confrontare due colonne di Excel, di oltre 4000 campi, e ricavarne le differenze.

Come possiamo confrontare 2 colonne in Excel?

Le prime due cose che ho fatto sono state:

  1. trasformare tutti i campi in modo che fossero uguali, trasformando tutto in MAIUSCOLO. Come facciamo? Semplice, apriamo Notepad++, incolliamo tutti i dati della colonna A, selezioniamo tutto (Ctrl+A) e teniamo premuto contemporaneamente Ctrl+Shift(maiuscola)+U. In questo modo avremo trasformato tutto in maiuscolo. Ri-incolliamo il risultato in Excel, sempre nella colonna A, e facciamo la stessa cosa con la colonna B.
  2. Per sicurezza, in Excel, rimuoviamo eventuali dati duplicati. Selezioniamo la colonna A, rechiamoci nel tab dati e premiamo il bottone Rimuovi Duplicati.

Ora arriva la parte divertente:

io volevo far si che la colonna C riportasse tutti i valori della colonna A che NON sono presenti in colonna B; ecco quale formula usare:

=SE(CONTA.SE(B:B;A1)=0;CONCATENA(“Valore presente in A : “;A1;” e non presente in B”);””)

Ora trasciniamo il contenuto della cella C1 (quello con la formula) verso il basso, tirandolo dall'angolo in basso a destra della cella, fino in fondo ai campi che contengono valori.

Ora voglio che la colonna D riporti tutti i valori della colonna B che NON sono presenti in colonna A; ecco quale formula usare:

In colonna D invece metto i valori di B NON presenti nella colonna A, quindi in D1 :

Codice:

=SE(CONTA.SE(A:A;B1)=0;CONCATENA(“Valore presente in B : “;B1;” e non presente in A”);””)

ora trasciniamo ancora.
Et voilà, avremo completato il nostro confronto in Excel!
Like
Like Love Haha Wow Sad Angry

CONDIVIDI QUESTO ARTICOLO


Comment Policy:

I commenti che vengono espressi su questo sito, rispecchiano il pensiero di coloro i quali li esprimono. Siate, pertanto, educati e cortesi nei confronti di chiunque. Utilizzate solo il vostro vero nome e i vostri profili social per collegarvi. Utilizzare profili falsi porterà alla cancellazione del commento, al blocco dello username, al ban dell'IP dal sito e ad una eventuale segnalazione dell'IP stesso alle autorità competenti. Sul sito non sono permessi commenti anonimi, pertanto è necessario che vi autentichiate con uno dei servizi che potete trovare qui sotto. Sono ammessi l'utilizzo di immagini e link nei commenti, ma con moderazione e sempre nel rispetto altrui.