Come confrontare 2 colonne in Excel e ricavarne le differenze

In Guide by RobertoLeave a Comment

Like
Like Love Haha Wow Sad Angry

Ieri un collega mi ha chiesto aiuto per confrontare due colonne di Excel, di oltre 4000 campi, e ricavarne le differenze.

Come possiamo confrontare 2 colonne in Excel?

Le prime due cose che ho fatto sono state:

  1. trasformare tutti i campi in modo che fossero uguali, trasformando tutto in MAIUSCOLO. Come facciamo? Semplice, apriamo Notepad++, incolliamo tutti i dati della colonna A, selezioniamo tutto (Ctrl+A) e teniamo premuto contemporaneamente Ctrl+Shift(maiuscola)+U. In questo modo avremo trasformato tutto in maiuscolo. Ri-incolliamo il risultato in Excel, sempre nella colonna A, e facciamo la stessa cosa con la colonna B.
  2. Per sicurezza, in Excel, rimuoviamo eventuali dati duplicati. Selezioniamo la colonna A, rechiamoci nel tab dati e premiamo il bottone Rimuovi Duplicati.

Ora arriva la parte divertente:

io volevo far si che la colonna C riportasse tutti i valori della colonna A che NON sono presenti in colonna B; ecco quale formula usare:

=SE(CONTA.SE(B:B;A1)=0;CONCATENA(“Valore presente in A : “;A1;” e non presente in B”);””)

Ora trasciniamo il contenuto della cella C1 (quello con la formula) verso il basso, tirandolo dall'angolo in basso a destra della cella, fino in fondo ai campi che contengono valori.

Ora voglio che la colonna D riporti tutti i valori della colonna B che NON sono presenti in colonna A; ecco quale formula usare:

In colonna D invece metto i valori di B NON presenti nella colonna A, quindi in D1 :

Codice:

=SE(CONTA.SE(A:A;B1)=0;CONCATENA(“Valore presente in B : “;B1;” e non presente in A”);””)

ora trasciniamo ancora.
Et voilà, avremo completato il nostro confronto in Excel!

Roberto Administrator
Info su di me
Informatico di professione. Nerd per passione. Totalmente malato per la tecnologia.
Sono una persona socievole, gentile ed educata. Sono mattiniero, ma anche notturno.
Amo la compagnia delle persone che mi piacciono e so dare molto più di ciò che mi si chiede.
Preferisco fare shopping piuttosto che passare una giornata in piscina
Odio volare, ho il terrore di volare!
Amo le giornate di pioggia e la neve. Odio il caldo.
Ho una memoria eccezionale e questo non è quasi mai un bene, anzi…
Sono esageratamente testardo, quando penso ne valga la pena. So ciò che voglio e lotto sempre, finché posso, per ottenerlo.
Sono molto pretenzioso. È molto facile deludermi e quasi impossibile sorprendermi.
Sono impulsivo, stronzo, ma sempre leale e sincero.
I filtri dell’imbarazzo, della delicatezza e della vergogna a me non li hanno applicati.
Sono molto vendicativo e rancoroso, ma – soprattutto – molto difficilmente dimentico un torto e raramente perdono chi me lo ha fatto.
Odio, in assoluto, le falsità, le menzogne ed essere preso per il culo.

QUI, se volete, potete leggere qualcosa di più su di me; la versione completa.
×
Roberto Administrator
Informatico di professione. Nerd per passione. Totalmente malato per la tecnologia.
Sono una persona socievole, gentile ed educata. Sono mattiniero, ma anche notturno.
Amo la compagnia delle persone che mi piacciono e so dare molto più di ciò che mi si chiede.
Preferisco fare shopping piuttosto che passare una giornata in piscina
Odio volare, ho il terrore di volare!
Amo le giornate di pioggia e la neve. Odio il caldo.
Ho una memoria eccezionale e questo non è quasi mai un bene, anzi…
Sono esageratamente testardo, quando penso ne valga la pena. So ciò che voglio e lotto sempre, finché posso, per ottenerlo.
Sono molto pretenzioso. È molto facile deludermi e quasi impossibile sorprendermi.
Sono impulsivo, stronzo, ma sempre leale e sincero.
I filtri dell’imbarazzo, della delicatezza e della vergogna a me non li hanno applicati.
Sono molto vendicativo e rancoroso, ma – soprattutto – molto difficilmente dimentico un torto e raramente perdono chi me lo ha fatto.
Odio, in assoluto, le falsità, le menzogne ed essere preso per il culo.

QUI, se volete, potete leggere qualcosa di più su di me; la versione completa.
Like
Like Love Haha Wow Sad Angry

CONDIVIDI QUESTO ARTICOLO